Latest news 2021-09-06: new blog post "Legacy Documents and TeX Live Docker Images".

Bug Tracker

ID 65🔗
Date: 2014-08-27 14:08:04
Status Open
Sign in if you want to bump this report.
Category mfirstuc
Version 1.09
Summary Fails with UTF-8 input
OS Ubuntu 14.04

Sign in to subscribe to notifications about this report.

Description

The attached MWE fails to compile. The commented out line shows a workaround, but it would be nice if the problem didn't arise!

MWE

Download (184B)

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8x]{inputenc}
\usepackage{mfirstuc}

\begin{document}
%\makefirstuc{'Prentice}
\makefirstuc{’Prentice}
\end{document}

Evaluation

This is a documented feature. From the user manual:

Note that non-Latin or accented characters appearing at the start of the text must be placed in a group (even if you are using the inputenc package) due to expansion issues.

Comments

0 comments.


Add Comment

Name (optional):

Are you human? Please confirm the bug report ID (which can be found at the top of this page) or login if you have an account.

Comment:

You can use the following markup:

Block:

[pre]Displayed verbatim[/pre]
[quote]block quote[/quote]

In line:

[tt]code[/tt]
[file]file/package/class name[/file]
[em]emphasized text[/em]
[b]bold text[/b]
[url]web address[/url] [sup]superscript[/sup]
[sub]subscript[/sub]

Ordered list:
[ol]
[li]first item[/li]
[li]second item[/li]
[/ol]

Unordered list:
[ul]
[li]first item[/li]
[li]second item[/li]
[/ul]

You can use the Preview button to review your message formatting before submitting.

Page permalink: https://www.dickimaw-books.com/bugtracker.php?key=65